博客园 首页 私信博主 显示目录 隐藏目录 管理

G - A+B for Input-Output Practice (VI)

 
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Your task is to calculate the sum of some integers. 
 

Input

Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line. 
 

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 
 

Sample Input

4 1 2 3 4
5 1 2 3 4 5
 

Sample Output

10
15
 
题解:注意Input contains multiple test cases这句话
 
 
#include<stdio.h>
int main()
{
    int n,a;
   while(scanf("%d",&n)!=EOF)
   {
       int sum=0;
       for(int i=1;i<=n;i++)
     {
         scanf("%d",&a);
         sum=sum+a;
     }
      printf("%d\n",sum);
   }
    return 0;
}

 

posted @ 2015-10-15 19:16  hfcnal  阅读(442)  评论(0编辑  收藏  举报