博客园 首页 私信博主 显示目录 隐藏目录 管理

D题 - A+B for Input-Output Practice (III)

 

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

Your task is to Calculate a + b.
 

Input

Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed. 
 

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input

1 5 10 20 0 0
 

Sample Output

6 30

 

题解;此题有个特殊要求,输入两个0时才会程序结束

#include<stdio.h>
int main()
{
    int a,b;
    while(scanf("%d %d",&a,&b))
    {
        if(a==0&&b==0)break;
        printf("%d\n",a+b); 
    }
    return 0;
}

 

posted @ 2015-10-14 21:03  hfcnal  阅读(703)  评论(0编辑  收藏  举报