1021 FIBERNACI

 hdu1021
分类: 数学 2011-08-12 11:42 652人阅读 评论(0) 收藏 举报
integernumbersinputeach
Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15238    Accepted Submission(s): 7140


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0
1
2
3
4
5
 

Sample Output
no
no
yes
no
no
no
 

 
Print the word"yes" if 3 divide evenly into F(n);Print the word"no" if not.

这里m取值为3,则可将公式条件演变为:

综上所述,可得到以下对应关系:F(0)= 1, F(1) = 2, F(n) = ( F(n-1) + F(n-2)  )( mod 3) (n>=2).

index  0  1  2  3  4  5  6  7  8  9  10  11  12  13

value  1  2  0  2  2  1  0  1  1  2   0   2   2  1

print  no no yes no  no no yes  no  no  no  yes  no  no  no

这样我们就得到了如下规律:从第2个开始每隔4个循环一次。

 #include<stdio.h>
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF)
 {
  if((n-2)%4!=0)
   printf("no\n");
  else
   printf("yes\n");
 }
 return 0;
}

 

posted @ 2014-05-06 09:43  盒子先生★  阅读(129)  评论(0编辑  收藏  举报