HDU 1001 Sum Problem

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
AC源代码(Java语言):
import java.math.BigDecimal;
import java.math.RoundingMode;
import java.util.Scanner;

public class Main{
//    public final static double pi = 3.1415927;
    public static void main(String[] args) {
        boolean flag = false;
        
        Scanner sin=new Scanner(System.in);
        while(sin.hasNextInt()){
            long sum = 0;
            int num = sin.nextInt();
            for(int i=0; i<=num; i++){
                sum += i;
            }
            System.out.println(sum);
            System.out.println();
        }
    }
}
View Code

 

posted @ 2017-05-10 17:37  世界和“你”  阅读(93)  评论(0编辑  收藏  举报