hust1010 The Minimum Length
题目描述
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the
shortest possible string A. For example, A="abcdefg". I got abcdefgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
输入
Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.
输出
For each line, output an integer, as described above.
样例输入
bcabcab efgabcdefgabcde样例输出
3
7
这题就是找最小的循环节是多少,直接用len-next[len]就行了。这里补充下next[i]的含义:1.指的是前i个字符前缀和后缀相同的匹配值。2.指的是如果s[i]不匹配,那么下一个要和当前字母匹配的字母的位置。next[i],i的范围是[0,n],不是[0,n-1].
#include<stdio.h>
#include<string.h>
char s[1000006];
int len,next[1000006];
void nextt()
{
int i,j;
i=0;j=-1;
memset(next,-1,sizeof(next));
while(i<len){
if(j==-1 || s[i]==s[j]){
i++;j++;next[i]=j;
}
else j=next[j];
}
}
int main()
{
int n,m,i,j,T;
while(scanf("%s",s)!=EOF)
{
len=strlen(s);
nextt();
printf("%d\n",len-next[len]);
}
return 0;
}