zoj3471 Most Powerful

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


题意是有n个气球,n的范围是1~n,每两个气球碰撞都会产生一定的能量,并且有一个气球会消失,问最后剩下一个气球的时候最多能产生多少能量。可以用状态压缩,设0表示气体存在,1表示气体消失,状态转移方程dp[state]=max{dp[state],dp[state']+a[i][j]}.

#include<stdio.h>
#include<string.h>
int a[15][15],dp[1500];
int max(int a,int b){
	return a>b?a:b;
}
int main()
{
	int n,m,i,j,s,ans;
	while(scanf("%d",&n)!=EOF && n!=0)
	{
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				scanf("%d",&a[i][j]);
			}
		}
		memset(dp,0,sizeof(dp));
		for(s=1;s<(1<<n);s++){
			for(j=1;j<=n;j++){
				if(s&(1<<(j-1))){
					for(i=1;i<=n;i++){
						if( !(s&(1<<(i-1))) ){
							dp[s]=max(dp[s],dp[s-(1<<(j-1))]+a[i][j]);
						}
					}
				}
			}
		}
		ans=0;
		for(i=1;i<=n;i++){
			if(dp[(1<<n)-1-(1<<(i-1))]>ans)ans=dp[(1<<n)-1-(1<<(i-1))];
		}
		printf("%d\n",ans);
	}
	return 0;
}


posted @ 2015-06-23 20:29  Herumw  阅读(88)  评论(0编辑  收藏  举报