hdu1710(二叉树的历遍)

/*
Binary Tree Traversals
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4644    Accepted Submission(s): 2113


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

 

Sample Output

7 4 2 8 9 5 6 3 1

 

Source
HDU 2007-Spring Programming Contest
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1711 1708 1707 1709 1509 
*/
#include <iostream>
#include<stdlib.h>
#include<stdio.h>
using namespace std;
const int Nmax=1001;
int pre[Nmax];
int in[Nmax];
int post[Nmax];
struct BTree
{
    int data;
    BTree *l;
    BTree *r;
}*p;
BTree* creatBT(int ls,int rs,int pos)
{
    BTree *p = new BTree;
    if(ls==rs)
        return NULL;
    for(int i=ls; i<rs; i++)
    {
        if(in[i]==pre[pos])
        {
            p->data=pre[pos];
            p->l=creatBT(ls,i,pos+1);
            p->r=creatBT(i+1,rs,pos+1+i-ls);
        }
    }
    return p;
}
void postTra(BTree* pt)
{
    if(pt==NULL)
        return;
    postTra(pt->l);
    postTra(pt->r);
    if(pt==p)
        printf("%d\n",pt->data);
    else
        printf("%d ",pt->data);
}
int main()
{
    int i,n;
    while(scanf("%d",&n)!=EOF)
    {
        p=NULL;
        for(i=0; i<n; i++)
            scanf("%d",&pre[i]);
        for(i=0; i<n; i++)
            scanf("%d",&in[i]);
        p=creatBT(0,n,0);
        postTra(p);
    }
    return 0;
}

 

posted @ 2015-09-22 17:15  myth_HG  阅读(450)  评论(0编辑  收藏  举报