poj-1083-Moving Tables(hdu-1050)

Moving Tables
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 23681        Accepted: 7839
Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.
Output

The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 
Sample Output

10
20
30
Source

Taejon 2001

题意:公司有400个房间,单号对双号对门,中间有一条走廊,
现在要搬东西,给出要搬的次数,还有每次搬动的房间号,
每次搬动需要10分钟,搬动过程中的那段走廊不能被使用,
求最大搬动时长。

解析: 按a从大到小排序,开始我按b从大到小排序,一直wa,后来找到 一组测试数据发现按b排序时错误的。
67 121 115 337 215 15 83 9 144 249 本题还可以统计每个点进过的次数,所有点最大的次数即为移动的次数 */ #include<iostream> #include<algorithm> #include<queue> #include<stack> #include<map> #include<stdio.h> #include<stdlib.h> #include<math.h> #include<string.h> #include<string> using namespace std; #define maxn 460 struct Tab { int a; int b; bool operator < (const Tab & ta)const { return b<ta.b; } } tab[maxn],tab1[maxn]; int main() { int i,T,n,b,sum,k; scanf("%d",&T); while(T--) { scanf("%d",&n); for(i=0; i<n; i++) { scanf("%d%d",&tab[i].a,&tab[i].b); if(tab[i].a>tab[i].b) swap(tab[i].a,tab[i].b); } sum=0; int f=1; do { sort(tab,tab+n); k=0; b=tab[0].b; printf("第 %d 次\n%d -> %d\n",f,tab[0].a,tab[0].b); for(i=1; i<n; i++) { if(tab[i].a-b-b%2>=1) { printf("%d -> %d\n",tab[i].a,tab[i].b); b=tab[i].b; } else { tab1[k].a=tab[i].a; tab1[k].b=tab[i].b; k++; } } sum++; n=k; memcpy(tab,tab1,sizeof(tab1)); f++; }while(n); printf("%d\n",sum*10); } return 0; }
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<string>
using namespace std;
#define maxn 460
int main()
{
    int t,i,n,b,e;
    scanf("%d",&t);
    while (t--)
    {
        int c[200]={0},m=0;
        scanf("%d",&n);
        while (n--)
        {
            scanf("%d%d",&b,&e);
            if (b>e)
            {
                i=b;
                b=e;
                e=i;
            }
            for (i=(b-1)/2;i<=(e-1)/2;++i)++c[i];
        }
        for (i=0;i<200;++i)if (m<c[i])m=c[i];
        printf("%d\n",10*m);
    }
    return 0;
}

 

posted @ 2013-08-06 19:09  myth_HG  阅读(1848)  评论(1编辑  收藏  举报