hdu-4442-Physical Examination

/*

Physical Examination

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3390    Accepted Submission(s): 931


Problem Description
WANGPENG is a freshman. He is requested to have a physical examination when entering the university.
Now WANGPENG arrives at the hospital. Er….. There are so many students, and the number is increasing!
There are many examination subjects to do, and there is a queue for every subject. The queues are getting longer as time goes by. Choosing the queue to stand is always a problem. Please help WANGPENG to determine an exam sequence, so that he can finish all the physical examination subjects as early as possible.
 

Input
There are several test cases. Each test case starts with a positive integer n in a line, meaning the number of subjects(queues).
Then n lines follow. The i-th line has a pair of integers (ai, bi) to describe the i-th queue:
1. If WANGPENG follows this queue at time 0, WANGPENG has to wait for ai seconds to finish this subject.
2. As the queue is getting longer, the waiting time will increase bi seconds every second while WANGPENG is not in the queue.
The input ends with n = 0.
For all test cases, 0<n≤100000, 0≤ai,bi<231.
 

Output
For each test case, output one line with an integer: the earliest time (counted by seconds) that WANGPENG can finish all exam subjects. Since WANGPENG is always confused by years, just print the seconds mod 365×24×60×60.
 

Sample Input
5
1 2
2 3
3 4
4 5
5 6
0
 

Sample Output
1419
Hint

In the Sample Input, WANGPENG just follow the given order. He spends 1 second in the first queue, 5 seconds in the 2th queue, 27 seconds in the 3th queue, 
169 seconds in the 4th queue, and 1217 seconds in the 5th queue. So the total time is 1419s. WANGPENG has computed all possible orders in his 
120-core-parallel head, and decided that this is the optimal choice.
 
 

Source
2012 Asia JinHua Regional Contest
题意:略。

思路:
对排在相邻的两个任务进行交换然后比较交换之前和交换之后的时间开销。 
设当前已经排了d秒,接下来任务是(a1,b1),(a2,b2) 
则有d+a1+b1*d+a2+b2*(d+a1+b1*d) <= d+a2+b2*d+a1+b1*(d+a2+b2*d) 
消元后,有b2*a1 <= b1*a2 
即a1/b1 <= a2/b2 
所以将任务按ai/bi从小到大排序即可得到最优解。  
在标程实现中,用叉积代替了除法防止精度问题。 
由于顺序可以决定,因此计算过程中直接取mod*/
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
using namespace std;
#define maxn 100100
struct PE
{
    int a;
    int b;
    bool operator < (const PE& p) const
    {
        return a*1.0/(b*1.0)<p.a*1.0/(p.b*1.0);
    }
}pe[maxn];
int main()
{
    int n,i;
    __int64 sum;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        scanf("%d%d",&pe[i].a,&pe[i].b);
        sort(pe,pe+n);
        sum=0;
        for(i=0;i<n;i++)
        {
            sum%=365*24*60*60;
            sum+=pe[i].b%(365*24*60*60)*sum+pe[i].a%(365*24*60*60);
        }
        sum%=365*24*60*60;
        printf("%I64d\n",sum);
    }
    return 0;
}

 

posted @ 2013-08-03 15:24  myth_HG  阅读(364)  评论(0编辑  收藏  举报