数组比较,查找,排序
Problem G
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 7 Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Input
1. a dictionary, which consists of at least one and at most 100 words, one per line; 2. a line containing XXXXXX, which signals the end of the dictionary; 3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 4. another line containing XXXXXX, which signals the end of the file.
All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
Output
Sample Input
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
Sample Output
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******
#include<iostream>
#include<stdio.h>
#include <algorithm>
#include<cstring>
using namespace std;
int main()
{
int l=0,i=0,j=0,k=0,h,m,q,w,s,g;
char a[999][102],c[102],b[999][102],a1[999][102],d[999][102];
while(cin>>c)
{
if(strcmp(c,"XXXXXX")==0)
{
l++; if(l==2) break;
}
if(l==0&&strcmp(c,"XXXXXX"))
{
strcpy(a[i],c);
i++;
strcpy(a1[k],c);
k++;
}
if(l==1&&strcmp(c,"XXXXXX")) strcpy(b[j++],c);
}
for(h=0;h<k;h++)
sort(a1[h],a1[h]+strlen(a1[h]));
for(m=0;m<j;m++)
sort(b[m],b[m]+strlen(b[m]));
for(m=0;m<j;m++)
{
w=0; q=0; for(h=0;h<i;h++)
{
if(strcmp(a1[h],b[m])==0)
{
strcpy(d[w],a[h]);
w++;
q=1;
}
}
if(h==i&&q==0)
cout<<"NOT A VALID WORD"<<endl;
else
{
for(s=0;s<w;s++)
for(g=s+1;g<w;g++)
if(strcmp(d[s],d[g])>0)
{
strcpy(c,d[g]);
strcpy(d[g],d[s]);
strcpy(d[s],c);
}
for(s=0;s<w;s++)
cout<<d[s]<<endl;
}
cout<<"******"<<endl;
}
return 0;
}