A+B Coming 进制输入输出
A+B Coming
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3359 Accepted Submission(s): 2087
Problem Description
Many classmates said to me that A+B is must needs. If you can’t AC this problem, you would invite me for night meal. ^_^
Input
Input may contain multiple test cases. Each case contains A and B in one line. A, B are hexadecimal number. Input terminates by EOF.
Output
Output A+B in decimal number in one line.
Sample Input
1 9 A B a b
Sample Output
10 21 21
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
int x,y;
while(scanf("%x%x",&x,&y)!=EOF)//以十六进制输入,o为八进制,没有二进制输入法。
{
printf("%d\n",x+y);
}
return 0;
}
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
int x,y;
while(scanf("%x%x",&x,&y)!=EOF)//以十六进制输入,o为八进制,没有二进制输入法。
{
printf("%d\n",x+y);
}
return 0;
}