A1059. 求解二元整数不定方程

问题描述

  求解形如ax+by<=m不定方程的解,其中x,y>0,y>=x;a,b为正整数
输入格式
  具体的a,b 和m的值,以逗号隔开。
输出格式
  打印该不定方程的所有解,每行打印该不定方程个一组解,每组解的x和y用逗号分隔。顺序为按照x递增,如果x值相等,按y递增。
样例输入
1,1,4
样例输出
1,1
1,2
1,3
2,2
数据规模和约定
  1<=a, b, m<=1000。
package www.tsinsen.com;

import java.util.Scanner;

public class A1059 {

    /**
     * @param args
     */
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner scan=new Scanner(System.in);
        String str=scan.next();
        String[] strs=str.split(",");
        int a=Integer.parseInt(strs[0]);
        int b=Integer.parseInt(strs[1]);
        int m=Integer.parseInt(strs[2]);
        for(int x=1;x<m/a;x++){
            for(int y=x;y<m/b;y++){
                if(a*x+b*y<=m){
                    System.out.println(x+","+y);
                }
            }
        }
    }
    
}

 

posted @ 2018-03-07 22:18  henu小白  阅读(278)  评论(0编辑  收藏  举报