GNS模拟器调试Tips
Summary
Win10 安装GNS3-2.1.3-all-in-one.exe,默认安装,若附带安装的其他组件因网络原因安装不上,先不管,点击取消即可。
安装完GNS3后可以启动。
<不能正常运行的话,可以试试安装其他旧版的gns如1.5或1.3>
经测试添加了c7200 256M 思科镜像,之前下载的其他镜像都有报错。
添加完成后,
**如果Test Router 的WAN口IP 192.168.10.1 连接Win10的本地网卡IP 192.168.10.134
两者应可互ping 通,否则请确认是否禁止了ping 回显功能。
root@router:~# ping 192.168.10.134 -I 192.168.10.1
PING 192.168.10.134 (192.168.10.134) from 192.168.10.1: 56 data bytes
64 bytes from 192.168.10.134: seq=0 ttl=64 time=0.885 ms
64 bytes from 192.168.10.134: seq=1 ttl=64 time=0.573 ms
64 bytes from 192.168.10.134: seq=2 ttl=64 time=0.536 ms
C:\Users\Administrator>ping 192.168.10.1 -S 192.168.10.134
正在 Ping 192.168.10.1 从 192.168.10.134 具有 32 字节的数据:
来自 192.168.10.1 的回复: 字节=32 时间<1ms TTL=64
来自 192.168.10.1 的回复: 字节=32 时间<1ms TTL=64
来自 192.168.10.1 的回复: 字节=32 时间<1ms TTL=64
DHCP
GNS3中新建工程添加R1思科路由器, Cloud1,添加R2做临时测试
#R1 更改了如下配置
!
ip dhcp pool dhcp10.1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.11
dns-server 192.168.10.11
!
ip dhcp pool dhcp20.1
network 192.168.20.0 255.255.255.0
default-router 192.168.20.11
dns-server 192.168.20.11
!
interface Ethernet1/0
ip address 192.168.10.11 255.255.255.0
duplex half
!
interface Ethernet1/1
ip address 192.168.20.11 255.255.255.0
duplex half
!
#R2
interface FastEthernet0/0
ip address dhcp
duplex half
!
Test Router WAN口配置改为dhcp方式从R1获取IP
#R1 Check
R1#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
192.168.10.1 0100.50c2.1d93.5a Aug 12 2018 03:08 PM Automatic
192.168.20.1 0063.6973.636f.2d63. Aug 12 2018 03:06 PM Automatic
6130.322e.3334.6230.
2e30.3030.302d.4661.
302f.30
因此,Both R2 and Test Router obtain dhcp ip from R1
Switch
在上一节的基础上添加switch接线.
#R1
R1#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
192.168.10.1 0100.50c2.1d93.5a Aug 12 2018 03:08 PM Automatic
192.168.10.2 0063.6973.636f.2d63. Aug 12 2018 03:50 PM Automatic
6130.322e.3334.6230.
2e30.3030.302d.4661.
302f.30
192.168.20.1 0063.6973.636f.2d63. Aug 12 2018 03:06 PM Automatic
6130.322e.3334.6230.
2e30.3030.302d.4661.
302f.30
#R2 ip 192.168.10.2
R2#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
#Test Router ip 192.168.10.1
root@router:~# ping 192.168.10.2 -I 192.168.10.1
PING 192.168.10.2 (192.168.10.2) from 192.168.10.1: 56 data bytes
64 bytes from 192.168.10.2: seq=0 ttl=255 time=21.744 ms
64 bytes from 192.168.10.2: seq=1 ttl=255 time=3.356 ms
64 bytes from 192.168.10.2: seq=2 ttl=255 time=5.902 ms