dp ZOJ 3956

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3956

 

Course Selection System

Time Limit: 1 Second      Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

 

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

 

 

 

题目大意:

给你一个$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$ 这样的式子,求这个式子的最大值。

 

思路:我们另sigma h = x, sigma c = y。然后化简以后得到,x(x - y) - y*y,所以当y固定,x越大越好,所以就dp一下

dp(i)表示目前y的总和为i的情况下x的最大值。

//看看会不会爆int!数组会不会少了一维!
//取物问题一定要小心先手胜利的条件
#include <bits/stdc++.h>
using namespace std;
#pragma comment(linker,"/STACK:102400000,102400000")
#define LL long long
#define ALL(a) a.begin(), a.end()
#define pb push_back
#define mk make_pair
#define fi first
#define se second
#define haha printf("haha\n")
const int maxn = 50010;
int dp[maxn];
int h[maxn];
int c[maxn];
int main(){
    int T;
    scanf("%d" , &T);
    while(T --){
        int n;
        scanf("%d" , &n);
        int sum = 0;
        for(int i =1 ; i <= n ; ++ i){
                scanf("%d%d" , &h[i] , &c[i]);
                sum += c[i];
        }
        memset(dp , -1 , sizeof(dp));
        for(int i = 1 ; i <= n ; ++ i){
            for(int j = sum ; j >= 0 ; -- j){
                if(dp[j] != -1){
                    dp[j + c[i]] = max(dp[j + c[i]] , dp[j] + h[i]);
                }
            }
            dp[c[i]] = max(dp[c[i]] , h[i]);
        }
        long long ans = 0;
        for(int i = 1 ; i <= sum ; ++ i){
                if(dp[i] != -1)
            ans = max(ans , (long long)dp[i] * (long long)dp[i] - (long long)dp[i] * (long long )i - (long long)i * (long long)i);
        }
        printf("%lld\n" , ans);
    }
    return 0;
}
View Code

 

posted @ 2017-04-10 19:08  知る奇迹に  阅读(165)  评论(0编辑  收藏  举报