A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21849   Accepted: 7379

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

思路:给出一个国际棋盘的大小,判断马能否不重复的走过所有格,并记录下其中按字典序排列的第一种路径。

"马的遍历"是一道经典回溯题,当然还是DFS...这题有3个要密切注意的地方:

1、题目要求以"lexicographically"方式输出,也就是字典序...一开始没看懂这个词结果WA了N次...要以字典序输出路径,那么方向数组就要以特殊的顺序排列了...这样只要每次从dfs(1,1)开始搜索,第一个成功遍历的路径一定是以字典序排列...

2、国际象棋的棋盘,横行为字母,表示横行坐标的是y;纵行为数字,表示纵行的坐标是x...一开始又搞反了...

3、虽然题目没说,但是这道题最后一组数据后是没有空行的...否则会PE...



代码:
#include <stdio.h>
#include <stdlib.h>
#define MAX 27
int map[MAX][MAX], sx[MAX], sy[MAX];
int dir[8][2] = {{-2, -1}, {-2, 1}, {-1, -2}, {-1, 2},{1, -2}, {1, 2}, {2, -1}, {2, 1}};
int p, q, sign, step;
void dfs(int i, int j)
{
if (sign)
 
return;
   
int x, y, k;
   
step++;
   
sx[step] = i;
   
sy[step] = j;
   
if(step == p * q)
   
{
       
sign = 1;
       
return;
   
}
   
map[i][j] = 1;
   
for (k = 0; k < 8; k++)
   
{
       
y = j + dir[k][0];
       
x = i + dir[k][1];
       
if (map[x][y] == 0 && x > 0 && x <= p && y > 0 && y <= q)
       
{
   
           
dfs(x, y);
           
step--;
       
}
   
}
   
map[i][j] = 0;

}
 


int main()

{
   
int i, j, n, t = 0;
   
scanf("%d", &n);
   
while(n--)
   
{
       
sign = 0;
       
step = 0;
       
t++;
       
scanf("%d%d", &p, &q);
       
for (i = 1; i <= p; i++)
       
{
           
for(j = 1; j <= q; j++)
           
{
               
map[i][j] = 0;
           
}
       
}
       
dfs(1, 1);
       
printf("Scenario #%d:\n", t);
       
if (sign)
       
{
           
for (i = 1; i <= p * q; i++)
           
{
               
printf("%c%d", sy[i] + 64, sx[i]);
           
}
           
printf("\n");
       
}
       
else
       
{
           
printf("impossible\n");
       
}
       
if (n != 0) printf("\n");
   
}
   
//system("pause");
   
return 0;

}

链接:http://poj.org/problem?id=2488