Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 32071   Accepted: 9866

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4



代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
using namespace std;
int n,k;
queue<int>Q;
#define N 100005
int visit[N];
int num[N];

int BFS(int x)
{
   Q.push(x);
   visit[x]=1;
   int a,b;
   while(!Q.empty())
   {
    a=Q.front();
    Q.pop();
    for(int i=0;i<3;i++)
    {
       if(i==0)
    b=a+1;
    else if(i==1)
    b=a-1;
    else
    b=2*a;
    if(b<0||b>N)
    continue;
    if(!visit[b])
    {
    Q.push(b);
    visit[b]=1;
    num[b]=num[a]+1;     
    if(b==k)
    return num[b];
    }   
    }    
   }  
}

int  main()
{
  scanf("%d%d",&n,&k);
  memset(num,0,sizeof(num)); 
  memset(visit,0,sizeof(visit));
  if(n>=k)
  printf("%d\n",n-k);
  else
  printf("%d\n",BFS(n));
  //system("pause");
  return 0;
}

链接:http://poj.org/problem?id=3278