Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10169    Accepted Submission(s): 3321


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
 
代码:

#include<stdio.h>
#include<string.h>
#define N 1000005
#define INF -(1<<30)
#define MX(a,b) (a>b?a:b)
int a[N];
int dp[N];//保留最优解;

int pre[N];//保留前一个状态的最大值;
int n,m;


int main()
{
   while(scanf("%d%d",&m,&n)!=-1)
   {
     memset(dp,0,sizeof(dp));
  memset(pre,0,sizeof(pre));
  int max;
  for(int i=1;i<=n;i++)
   scanf("%d",&a[i]);
   for(int i=1;i<=m;i++) //段数;
   {
      max=INF;
   for(int j=i;j<=n;j++) //以j结尾;
   {
      dp[j]=MX(dp[j-1],pre[j-1])+a[j];
   pre[j-1]=max;
   max=MX(max,dp[j]);   
         }    
   } 
   printf("%d\n",max);       
   }  
   return 0;
}

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1024