Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 654    Accepted Submission(s): 452


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

 

Sample Input
3 4 1011 1001 0001 3 4 1010 1001 0001
 

 

Sample Output
4 2
 
思路:可以将列任意移动,我们肯定要尽量将高度大的放在一起,所以,我们可以将高度从大到小排序,即如果将1,2…i个矩形连在一起,它的高应该是h[i],所以面积显然是h[i] * i,然后我们就枚举i从1到n,就可以解决这个问题了。
 
代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace  std;
#define MX(a,b) (a>b?a:b)
int a[1005],num[1005];
int n,m;


bool cmp(int a,int b)
{
   return a>b;  
}

int main()
{
   char c;
   while(scanf("%d%d",&n,&m)!=-1)
   {
      getchar();
      memset(num,0,sizeof(num));
   int max=0;
   for(int i=1;i<=n;i++)
   {
       for(int j=1;j<=m;j++)
    {
        scanf("%c",&c);
     if(c=='1')
     num[j]++;
     else
     num[j]=0;
     a[j]=num[j];    
    }    
    sort(a+1,a+m+1,cmp);
    for(int k=1;k<=m&&a[k];k++)
    max=MX(max,a[k]*k);
    getchar();
      }     
   printf("%d\n",max);   
   }  
   return 0;
}

链接:http://acm.hdu.edu.cn/showproblem.php?pid=2830