Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5851    Accepted Submission(s): 2631


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
代码:
#include<stdio.h>
#define N 1000005
#define M 10005
int a[N];
int b[M];
int next[M];
int n,m;
void getnext()
{
   int j=1;
   int k=0;
   next[0]=-1;
   next[1]=0;
   while(j<m-1)
   {
     if(b[j]==b[k])
    {
        next[j+1]=k+1;
        j++;
        k++;      
    } 
  else if(k==0)
  {
  next[j+1]=0;
  j++;
  }
  else
  k=next[k];
      
   }  
}
int KMP()
{
   int i=0;
   int j=0;
   while(i<n&&j<m)
   {
      if(a[i]==b[j])
     {
       i++;
       j++;     
      } 
   else if(j==0) 
   i++;
   else
   j=next[j];   
   }  
   if(j==m)
   return i-j+1;
   return -1;
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
      scanf("%d%d",&n,&m);
      for(int i=0;i<n;i++)
      scanf("%d",&a[i]);
       for(int i=0;i<m;i++)
        scanf("%d",&b[i]);
        if(n<m)
        printf("-1\n");
        else
        {
     getnext();
     printf("%d\n",KMP());  
     }
   }  
   return 0;
}
 链接:http://acm.hdu.edu.cn/showproblem.php?pid=1711