Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 628    Accepted Submission(s): 268


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
1 0
 代码:
#include<stdio.h>
#include<string>
using namespace std;
#define lowbit(a) (a&(-a))
#define N 1005
int map[N][N];
int visit[N][N];
int n;
void update(int x,int y,int p)
{
  for(int i=x;i<N;i+=lowbit(i))
    for(int j=y;j<N;j+=lowbit(j))
   map[i][j]+=p;  
}
int query(int x,int y)
{
   int sum=0;
   for(int i=x;i>0;i-=lowbit(i))
      for(int j=y;j>0;j-=lowbit(j))
      sum+=map[i][j];
   return sum;  
}
int main()
{
   memset(map,0,sizeof(map));
   memset(visit,0,sizeof(visit)); 
   int x,y;
   char s[3];
   scanf("%d",&n);
   while(n--)
   {
      scanf("%s",s);
   if(s[0]=='B')
   {
   scanf("%d%d",&x,&y);
   x++;
   y++;
   if(!visit[x][y])
   {
   update(x,y,1);
   visit[x][y]=1;
   }
   }
   if(s[0]=='D')
   {
      scanf("%d%d",&x,&y);
      x++;
      y++;
      if(visit[x][y])
      {
   update(x,y,-1);
   visit[x][y]=0;
   }     
   } 
   if(s[0]=='Q')
   {
      int x1,x2,y1,y2;     
   scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
   x1++,x2++,y1++,y2++;
   if(x1>x2)
   swap(x1,x2);
   if(y1>y2)
   swap(y1,y2);
   printf("%d\n",query(x2,y2)+query(x1-1,y1-1)-query(x1-1,y2)-query(x2,y1-1));      
   }  
   }
}