Flowers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1022    Accepted Submission(s): 513


Problem Description
As is known to all, the blooming time and duration varies between different kinds of flowers. Now there is a garden planted full of flowers. The gardener wants to know how many flowers will bloom in the garden in a specific time. But there are too many flowers in the garden, so he wants you to help him.
 

 

Input
The first line contains a single integer t (1 <= t <= 10), the number of test cases.
For each case, the first line contains two integer N and M, where N (1 <= N <= 10^5) is the number of flowers, and M (1 <= M <= 10^5) is the query times.
In the next N lines, each line contains two integer Si and Ti (1 <= Si <= Ti <= 10^9), means i-th flower will be blooming at time [Si, Ti].
In the next M lines, each line contains an integer Ti, means the time of i-th query.
 

 

Output
For each case, output the case number as shown and then print M lines. Each line contains an integer, meaning the number of blooming flowers.
Sample outputs are available for more details.
 

 

Sample Input
2 1 1 5 10 4 2 3 1 4 4 8 1 4 6
 

 

Sample Output
Case #1: 0 Case #2: 1 2 1
 
AC代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 10000005
int dp[N];
int t,n,m;
int main()
{
    int t;
    int cnt=1;
 scanf("%d",&t);
 while(t--)
 {
      printf("Case #%d:\n",cnt++);
      memset(dp,0,sizeof(dp));
   scanf("%d%d",&n,&m);
   int a,b;
   for(int i=0;i<n;i++)
   {
     scanf("%d%d",&a,&b);
  for(int j=a;j<=b;j++)
  dp[j]++;  
      } 
   int x;
   for(int i=0;i<m;i++)
   {
      scanf("%d",&x);
   printf("%d\n",dp[x]);    
   }  
    } 
    system("pause");
    return 0;
}