Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1033    Accepted Submission(s): 425


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
 

 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

 

Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

 

Sample Output
Case #1: Yes Case #2: No
 
AC代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int t,n;
int flage;
int cnt=1;
char  map[2000][2000];
int main()
{
   scanf("%d",&t);
   while(t--)
   {
      flage=0;
      scanf("%d",&n);      
   for(int i=0;i<n;i++)
        scanf("%s",map[i]);
       for(int i=0;i<n;i++)
   {
       for(int j=0;map[i][j]=='1'&&j<n;j++)//此处不是很明白;
    {
      for(int k=0;k<n;k++)
      {
      if(map[i][k]=='0'&&map[j][k]=='1')
      {
     flage=1;
     break;          
         }
   }
   if(flage)
   break;
    }   
    if(flage)
    break; 
      }
   if(flage)
   printf("Case #%d: Yes\n",cnt++);
   else
   printf("Case #%d: No\n",cnt++);  
   }  
   system("pause");
   return 0;
}
 链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324