觉得浮夸了四年,漠然发现原来是浮躁了四年!

hdu 2592(Counting Sheep )

Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
 

Sample Output

6 3
 
 
Problem analysis:
This is a basic  breadth first search(BFS) problem.
Use the template of the BFS can easy solve the problem.
Here is the detailed method of the problem:
复制代码
View Code
#include<iostream>
using namespace std;
#define n 105
char map[n][n];
int h,w;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
void flock(int x,int y)
{
    int i,nx,ny;
    map[x][y]='.';
    for(i=0;i<4;i++)
    {
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if(nx>=h||nx<0||ny>=w||ny<0)
            continue;
        if(map[nx][ny]!='#')
            continue;
        flock(nx,ny);
    }
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>h>>w;
        getchar();
        int i,j;
        for(i=0;i<h;i++)
         scanf("%s",map[i]);
        int count=0;
        for(i=0;i<h;i++)
            for(j=0;j<w;j++)
            {
                if(map[i][j]=='#')
                {
                    count++;
                    flock(i,j);
                }
            }
        cout<<count<<endl;
    }
    return 0;
}
复制代码

 

posted @   heat nan  阅读(181)  评论(0编辑  收藏  举报
编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
点击右上角即可分享
微信分享提示