觉得浮夸了四年,漠然发现原来是浮躁了四年!

A Simple Problem

 

Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.
 

 

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).
 

 

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.
 

 

Sample Input
2 2 3
 

 

Sample Output
-1 1
 

 

Author
HIT
Problem analyse:
This is very interesting math problem.In the equation " y^2 = n +x^2",  "x"and "y"are all variable, so it's hard to handle it.
So first we can use the equation to reduce the varibles:
y^2 = n +x^2 → n=(y-x)*(y+x)  and then we assume that(1) i=y-x;  and (2)y+x=n/i;  
with the equations (1) and (2),we can get a new equation x=(n/i-i)/2;
Now the problem is gonna easy!
  
复制代码
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        int i;
        i=(int)sqrt(double(n));
        for(i;i>0;i--)
        {
            if(n%i==0&&(n/i-i)%2==0&&n/i!=i)
            {
                cout<<(n/i-i)/2<<endl;
                break;
            }
        }
        if(i==0)
            cout<<"-1"<<endl;
    }
    return 0;
}
复制代码

 

 
posted @   heat nan  阅读(129)  评论(0编辑  收藏  举报
编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
点击右上角即可分享
微信分享提示