觉得浮夸了四年,漠然发现原来是浮躁了四年!

hdu 1385(Minimum Transport Cost) Floyd algorithm

Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

 

Source
 
Analysis:
After read the problem,we can see the problem can solve by Floyd algorithm.The N cities and the road between them make up a graph.But the prolem is not only  calculate the path cost between the two cities.The transportation fee is also consist of the tax  if the cargo passing other cities.So the problem has become more difficult. 
The transprtation free include  two parts:(1) The cost of the path we can use the Floyed algorithm to solve it.We regard the path cost as the edge of the weight. (2)The tax problem we can add a new array intermediate[],and the array we record the intermediate city.
Specific code:

#include<iostream>
using namespace std;
#define max 0xfffffff
int path_cost[100][100];
int intermediate[100][100];
int tax[100];
int N;
void Floyd()
{
 int i,j,k;
 for(i=1;i<=N;i++)       
  for(j=1;j<=N;j++)
   intermediate[i][j]=j;
 for(i=1;i<=N;i++)    //*heart code of the Floyd
  for(j=1;j<=N;j++)
   for(k=1;k<=N;k++)
   {
    int mediate_cost=path_cost[j][i]+path_cost[i][k]+tax[i];
    if(path_cost[j][k]>mediate_cost)
    {
     path_cost[j][k]=mediate_cost;
     intermediate[j][k]=intermediate[j][i];
    }
    if(path_cost[j][k]==mediate_cost)                //* the lexically smallest one
    {
     if(intermediate[j][k]>intermediate[j][i])
      intermediate[j][k]=intermediate[j][i];
    }
   }
}
int main()
{
 int i,j;
 while(scanf("%d",&N)&&N)
 {
  int length;
  for(i=1;i<=N;i++)
   for(j=1;j<=N;j++)
   {
    cin>>length;
    if(length==-1)
     path_cost[i][j]=max;
    else
     path_cost[i][j]=length;
   }
  for(i=1;i<=N;i++)
   cin>>tax[i];
  Floyd();
  int a,b;
  while(scanf("%d %d",&a,&b)&&(a!=-1||b!=-1))
  {
   printf("From %d to %d :\n",a,b);
   printf("Path: %d",a);
   int t=a;
   while(t!=b)
   {
    printf("-->%d",intermediate[t][b]);
    t=intermediate[t][b];
   }
   printf("\n");
   printf("Total cost : %d\n\n",path_cost[a][b]);
  }
 }
 return 0;
}


 

posted @   heat nan  阅读(138)  评论(0编辑  收藏  举报
编辑推荐:
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
点击右上角即可分享
微信分享提示