hdu 1002
Sum Problem
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164763 Accepted Submission(s): 38888
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
#include<iostream>
using namespace std;
int main()
{int i,n,sum=0;
while(cin>>n)
{
sum=0;
for(i=0;i<=n;i++)
{
sum=sum+i;
}
cout<<sum<<endl<<endl;
}
return 0;
}
using namespace std;
int main()
{int i,n,sum=0;
while(cin>>n)
{
sum=0;
for(i=0;i<=n;i++)
{
sum=sum+i;
}
cout<<sum<<endl<<endl;
}
return 0;
}
【推荐】还在用 ECharts 开发大屏?试试这款永久免费的开源 BI 工具!
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步