hdu 1002
Sum Problem
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 164763 Accepted Submission(s): 38888
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
#include<iostream>
using namespace std;
int main()
{int i,n,sum=0;
while(cin>>n)
{
sum=0;
for(i=0;i<=n;i++)
{
sum=sum+i;
}
cout<<sum<<endl<<endl;
}
return 0;
}
using namespace std;
int main()
{int i,n,sum=0;
while(cin>>n)
{
sum=0;
for(i=0;i<=n;i++)
{
sum=sum+i;
}
cout<<sum<<endl<<endl;
}
return 0;
}