B1004 成绩排名

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式

每个测试输入包含1个测试用例,格式为
第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
… … …
第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式

对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
结尾无空行

输出样例:

Mike CS991301
Joe Math990112

idea

  • 已知成绩范围为0~100==》不妨设max = -1, min = 101

solution1

#include <stdio.h>
struct student{
	char name[20];
	char id[20];
	int score;
};

int main(){
	int n, max, min, maxp = 0, minp = 0;
	scanf("%d", &n);
	student stu[n];
	for(int i = 0; i < n; i++){
		scanf("%s %s %d", stu[i].name, stu[i].id, &stu[i].score);
		if(i == 0){
			max = stu[i].score;
			min = max;
		}
		else{
			if(max < stu[i].score){
				max = stu[i].score;
				maxp = i;
			}
			if(min > stu[i].score){
				min = stu[i].score;
				minp = i;
			}
		}
	}
	printf("%s %s\n%s %s", stu[maxp].name, stu[maxp].id, stu[minp].name, stu[minp].id);
	return 0;
}

solution2

#include <stdio.h>
struct student{
	char name[20];
	char id[20];
	int score;
};

int main(){
	int n, max = -1, min = 101, maxp, minp;
	scanf("%d", &n);
	student stu[n];
	for(int i = 0; i < n; i++){
		scanf("%s %s %d", stu[i].name, stu[i].id, &stu[i].score);
		if(max < stu[i].score){
			max = stu[i].score;
			maxp = i;
		}
		if(min > stu[i].score){
			min = stu[i].score;
			minp = i;
		}
	}
	printf("%s %s\n%s %s", stu[maxp].name, stu[maxp].id, stu[minp].name, stu[minp].id);
	return 0;
}

solution3

#include <stdio.h>
struct student{
	char name[11];
	char id[11];
	int score;
}max, min, temp;
int main(){
	int n;
	max.score = -1;
	min.score = 101;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%s %s %d", temp.name, temp.id, &temp.score);
		if(temp.score > max.score) max = temp;
		if(temp.score < min.score) min = temp;
	}
	printf("%s %s\n%s %s", max.name, max.id, min.name, min.id);
	return 0;
}
posted @ 2022-01-06 11:18  Moliay  阅读(13)  评论(0编辑  收藏  举报