B1032 挖掘机技术哪家强

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第 1 行给出不超过 10
5
的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

solution

#include <stdio.h>
int main(){
	int n, t, id, score, maxId, maxScore = -1;
	scanf("%d", &n);
	int sum[n+1] = {0};
	t = n;
	while(t--){
		scanf("%d %d", &id, &score);
		sum[id] += score;
	}
	
	for(int i = 1; i <= n; i++){
		if(sum[i] > maxScore){
			maxId = i;
			maxScore = sum[i];
		}
	} 
	if(maxScore != -1)
		printf("%d %d", maxId, maxScore);
	else
		printf("1 0");
	return 0;
}
posted @ 2022-01-06 14:36  Moliay  阅读(11)  评论(0编辑  收藏  举报