又一版 A+B

Description

输入两个不超过整型定义的非负10进制整数A和B(<=231-1),输出A+B的m (1 < m <10)进制数。

Input

输入格式:测试输入包含若干测试用例。每个测试用例占一行,给出m和A,B的值。
当m为0时输入结束。

Output

输出格式:每个测试用例的输出占一行,输出A+B的m进制数。

Sample Input Copy

2 4 5
8 123 456
0

Sample Output Copy

1001
1103

solution

#include <stdio.h>
int main(){
	long long a, b, c;
	int m, result[50], n;
	while(scanf("%d", &m), m != 0){
		scanf("%lld%lld", &a, &b);
		c = a + b;
		n = 0;
		do{
			result[n++] = c % m;
			c /= m;
		}while(c != 0);
		for(int i = n - 1; i >= 0; i--){
			printf("%lld", result[i]);
		}
		printf("\n");
	}
	return 0;
}
posted @ 2022-01-15 20:18  Moliay  阅读(16)  评论(0编辑  收藏  举报