A1002 A+B for Polynomials

description

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

idea

  • 注意0 <= NK < … < N2 < N1 <=1000,则数组大小应为1001
    否则测试点二过不去~

solution

#include <stdio.h>
int main(){
	int k, count = 0;
	double a[1001] = {0};
	for(int i = 0; i < 2; i++){
		scanf("%d", &k);
		while(k--){
			double an;
			int n;
			scanf("%d%lf", &n, &an);
			a[n] += an;
		}
	}
	for(int i = 0; i < 1001; i++){
		if(a[i] != 0){
			count++;
		}
	}
	printf("%d", count);
	for(int i = 1000; i >= 0; i--){
		if(a[i] != 0)
			printf(" %d %.1f", i, a[i]);
	}
	return 0;
}
posted @ 2022-03-01 14:08  Moliay  阅读(10)  评论(0编辑  收藏  举报