A1009 Product of Polynomials

description

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

idea

  • 在输入第二个多项式时,可变输入边计算
  • 注意相乘的话,指数最大为2000,则答案数组应该为2001

solution

#include <stdio.h>
int main(){
	int k, n, count = 0;
	double a[1001] = {0}, r[2001] = {0}, an;
	scanf("%d", &k);
	while(k--){
		scanf("%d%lf", &n, &an);
		a[n] = an;
	}
	scanf("%d", &k);
	while(k--){
		scanf("%d%lf", &n, &an);
		for(int i = 0; i < 1001; i++){
			if(a[i] != 0)
				r[i + n] += an * a[i];
		}
	}
	for(int i = 0; i < 2001; i++){
		if(r[i] != 0)
			count++;
	}
	printf("%d", count);
	for(int i = 2000; i >= 0; i--){
		if(r[i] != 0)
			printf(" %d %.1f", i, r[i]);
	}
	return 0;
} 
posted @ 2022-03-01 14:54  Moliay  阅读(10)  评论(0编辑  收藏  举报