Biorhythms(poj 1006)

Description

人生来就有三个生理周期,分别为体力、感情和智力周期,它们的周期长度为23天、28天和33天。每一个周期中有一天是高峰。在高峰这天,人会在相应的方面表现出色。例如,智力周期的高峰,人会思维敏捷,精力容易高度集中。因为三个周期的周长不同,所以通常三个周期的高峰不会落在同一天。对于每个人,我们想知道何时三个高峰落在同一天。对于每个周期,我们会给出从当前年份的第一天开始,到出现高峰的天数(不一定是第一次高峰出现的时间)。你的任务是给定一个从当年第一天开始数的天数,输出从给定时间开始(不包括给定时间)下一次三个高峰落在同一天的时间(距给定时间的天数)。例如:给定时间为10,下次出现三个高峰同天的时间是12,则输出2(注意这里不是3)。

Input

输入四个整数:p, e, i和d。 p, e, i分别表示体力、情感和智力高峰出现的时间(时间从当年的第一天开始计算)。d 是给定的时间,可能小于p, e, 或 i。 所有给定时间是非负的并且小于365, 所求的时间小于21252。 

当p = e = i = d = -1时,输入数据结束。

Output

从给定时间起,下一次三个高峰同天的时间(距离给定时间的天数)。 

采用以下格式: 
Case 1: the next triple peak occurs in 1234 days. 

注意:即使结果是1天,也使用复数形式“days”。

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
/*
  中国剩余定理题目
  分析:
   设答案为n,则有 
   ①(n+d)%23=p;②(n+d)%28=e;③(n+d)%33=i;
   设M1=28*33=924,M2=23*33=759,M3=23*28=644;
   设 x1,x2,x3 
   则有 M1*x1=1(mod 23);M2*x2=1(mod 28);M3*x3=1(mod 33);
   解得最小正整数的x1=6,x2=19,x3=2;
   n=((M1*x1*23)+(M2*x2*28)+(M3*x3*33))mod 21252
    注:21252===>(23*28*33);
*/
#include<cstdio>
#include<iostream>
#define mod 21252
using namespace std;
int p,e,i,d,cnt;
void init()
{
    int ans=((924*6*p)%mod+(759*19*e)%mod+(644*2*i)%mod-d+mod)%mod;
    if(ans==0)ans=21252;
    printf("Case %d: the next triple peak occurs in %d days.\n",++cnt,ans);
}
int main()
{
    while(1)
    {
        scanf("%d%d%d%d",&p,&e,&i,&d);
        if(p==-1&&e==-1&&i==-1&&d==-1)break;
        init();
    }
    return 0;
}
View Code

 

posted @ 2016-07-10 18:15  karles~  阅读(153)  评论(0编辑  收藏  举报