1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3
 

Sample Output:

1
0
0

题意:

几个村庄联通在一起,当敌军占领一个村庄后,这个村庄与外界的联通联通路线被阻断,问要使剩下的村庄联通,需要新修建几条路线。

分析:

使用连接矩阵来表示联通的图,visited[]用来表示当前村庄是否被访问过,利用dfs()来寻找连通分量的个数,连通分量的个数-1就是所需要修建的路的条数。

 

Code:

#include<iostream>
#include<algorithm>
#include<cstdio>

using namespace std;

int v[1010][1010];
int visited[1010];
int n, k, m, c;

void dfs(int node) {
    visited[node] = 1;
    for (int i = 1; i <= n; ++i) {
        if (visited[i] == 0 && v[node][i] == 1) {
            dfs(i);
        }
    }
}

int main() {
    
    scanf("%d%d%d", &n, &k, &m);

    int x, y;
    for (int i = 0; i < k; ++i) {
        scanf("%d%d", &x, &y);
        v[x][y] = v[y][x] = 1;
    }

    for (int i = 0; i < m; ++i) {
        int cnt = 0;
        scanf("%d", &c);
        fill(visited, visited+1010, 0);
        visited[c] = 1;
        for (int j = 1; j <= n; ++j) {
            if (visited[j] == 0) {
                dfs(j);
                cnt++;
            }
        }
        cout << cnt-1 << endl;
    }

    return 0;
}

  

注意:

这里要使用scanf()函数来输入,如果使用cin来输入的话会超时。

 

posted @ 2020-03-29 17:05  Veritas_des_Liberty  阅读(208)  评论(0编辑  收藏  举报