2018中国大学生程序设计竞赛 - 网络选拔赛-A Buy and Resell (思维 贪心)

Buy and Resell

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.
 

 

Input
There are multiple test cases. The first line of input contains a positive integer T (T250), indicating the number of test cases. For each test case:
The first line has an integer n. (1n105)
The second line has n integers a1,a2,,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1ai109)
It is guaranteed that the sum of all n is no more than 5×105.
 

 

Output
For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.
 

 

Sample Input
3 4 1 2 10 9 5 9 5 9 10 5 2 2 1
 

 

Sample Output
16 4 5 2 0 0
Hint
In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0
 
 
分析:最大利益很容易达到,难点是最少交易次数,通过巧妙的标记可以达到对一次交易“反悔”的效果。
堆中物品分为两种(一种是一般的物品type=0,另一种是后悔的等价物type=1)
设当前城市价格为 p 
当卖出的是价值为 q 的一般物品时,向堆中加入一个价值为 p 的后悔等价物。
当卖出的是价值为 q 的后悔等价物时,向堆中加入一个价值为 p 的后悔等价物和一个价值为 q 的普通物品。
为加深理解,把它称为替罪羊思维。
#include <bits/stdc++.h>
using namespace std;
int n;
typedef long long LL;
struct node
{
    LL w;
    bool type;
    friend bool operator <(node x,node y)
    {
        return ((x.w<y.w)||(x.w==y.w&&x.type>y.type));
    }
};
multiset<node>Q;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        Q.clear();
        scanf("%d",&n);
        LL ans = 0;
        int cnt=0;
        for(int i = 0; i<n; i++)
        {
            LL x;
            scanf("%lld",&x);

            if(Q.size()==0)
                Q.insert(node{x,0});
            else
            {
                node ne=*Q.begin();
                if(ne.w<x)
                {
                    Q.erase(Q.begin());
                    ans+=x-ne.w;
                    if(ne.type==0)
                    {
                        cnt+=2;
                        Q.insert(node{x,1});
                    }
                    else
                    {
                        Q.insert(node{ne.w,0});
                        Q.insert(node{x,1});
                    }
                }
                else Q.insert(node{x,0});
            }
        }
        cout<<ans<<' '<<cnt<<endl;
    }
    return 0;
}
View Code

 

posted @ 2018-08-25 20:53  Gzhynl  阅读(180)  评论(0编辑  收藏  举报