Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
 
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 
Output
For each test case, output the encoded string in a line.
 
Sample Input
2
ABC
ABBCCC
 
Sample Output
ABC
A2B3C
 
My solution:
 
 
#include<iostream>
#include<string>
using namespace std;
int main(void)
{
    int n;
    char a,b;
    cin>>n;
    getchar();
    for (int i=0;i<n;i++)
    {
        b='\0';
        int j=0;
        while (a=getchar())
        {
            if (a=='\n') 
                {
                    if(j<=1) cout<<b;
                    if(j>1) cout<<j<<b;
                    cout<<endl;
                    break;
                }
            if (a==b)
            {
                j++;
            }
            if (a!=b)
            {
                if(j>1) cout<<j<<b;
                if(j==1) cout<<b;
                b=a;
                j=1;
            }
        }
    }
}