Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6
 
My solution:
#include<iostream>
using namespace std;
int main(){
    int N;cin>>N;
    for(int k=1;k<=N;k++){
        if(k-1)cout<<endl;
        int n;cin>>n;
        int i,j,beg,end,max=-11111111,sum,fig;
        for(i=j=1,sum=0;j<=n;j++){
            cin>>fig;
            sum+=fig;
            if(sum>max){max=sum;beg=i;end=j;}//a只在此处改变beg,和end 的大小
            if(sum<0){i=j+1;sum=0;}//如果sum小于零了,那么说明刚加进来的fig特别的小(小到这种“特殊”的程度)
            //试探性的以次为起点,如果后来的sum 比max 大,则前面的一连串就毫无意义(因为加上一个负值肯定会变小的)
        }
        cout<<"Case "<<k<<":\n";
        cout<<max<<" "<<beg<<" "<<end<<endl;
    }
    return 0;
}