Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 
Input
The input will consist of a series of integers n, one integer per line.
 
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 
Sample Input
1 100
 
Sample Output
1 5050
 
My solution:
 
#include<iostream>
using namespace std;
int main(void)
{
    int n;
    while (cin>>n)
    {
        int sum=0;
        sum=n%2==0?n/2*(n+1):(n+1)/2*n;
        cout<<sum<<endl<<endl;
    }
    return 0;
}