1013 Battle Over Cities——PAT甲级真题

1013 Battle Over Cities

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意:一共有N个城市,共有M条大陆链接这些城市,一共有K个重点城市,问如果破坏这K个重点城市,链接其他城市至少需要多少条道路。

大致思路:用并查集来链接城市,一次判断每个重点城市,把这些城市破坏,然后链接其他城市需要多少条道路。

代码:

#include <bits/stdc++.h>

using namespace std;

const int N = 1e6 + 10;
typedef pair<int, int> PII;
int fa[N];
int n, m, k;
vector<PII> edge;

int find(int x) {
    if (x != fa[x]) fa[x] = find(fa[x]);
    return fa[x];
}

int main() {
    scanf("%d%d%d", &n, &m, &k);
    for (int i = 0; i < m; i++) {
        int a, b;
        scanf("%d%d", &a, &b);
        edge.push_back({a, b});
    }
    vector<int> v(k);
    for (int i = 0; i < k; i++) cin >> v[i];
    for (int i = 0; i < k; i++) {
        for (int j = 1; j <= n; j++) fa[j] = j;
        int x = v[i];
        int cnt = n - 1;
        for (int r = 0; r < m; r++) {
            int a = edge[r].first,
                b = edge[r].second;  //要保证a和b都不是关键城市
            if (a != x && b != x && find(a) != find(b)) {
                fa[find(a)] = find(b);
                cnt--;
            }
        }
        printf("%d\n", cnt - 1);
    }
    return 0;
}

posted on 2021-02-24 09:46  翔鸽  阅读(24)  评论(0编辑  收藏  举报