1022 Digital Library——PAT甲级真题

1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意:让你模拟一个图书管理系统,输入图书的编号,名称,作者,关键字,出版社,出版年份。然后给出M个查询,让你根据相应的查询输出对应的图书编号。

大致思路:仔细审题我们可以知道最后只让输出的是对应的图书的编号,因此我们建立名称,作者,关键字,出版社,出版年份和编号之间的映射关系,这个时候就可以考虑到map应为最后要按照大小由小到达输出相应的图书编号,如果在排序的话会超时,但是set和map内部由红黑树实现自带排序功能。所以我们可以用 map<string, set<int>> mpTitle, mpAutor, mpKey, mpPublisher, mpYear 建立映射关系。在执行m次查询操作的时候直接可以用一个查询函数用来查找对应集合 void query(map<string, set<int>> mp, string str) .在都如key_word时我们可以用 while(cin >> key_words) 同时注意吸收空格和换行,当输入换行时结束输入。这道题一定要注意字符串的读入在使用 getline() 之前一定要用 getchar() 吸收 scanf 的换行,同时在输出的时候要注意最后两组测试数据给出的id不是七位数字但我们要输出7位数字,要格式化输出id,在函数传参的时候一定要加引用不然最后一组数据会超时。

代码:

#include <bits/stdc++.h>

using namespace std;

map<string, set<int>> mpTitle, mpAutor, mpKey, mpPublisher, mpYear;

void query(map<string, set<int>> mp, string str) {
    if (mp.find(str) == mp.end()) puts("Not Found");
    for (auto ite : mp[str]) {
        printf("%07d\n", ite);
    }
}

int main() {
    int n;
    scanf("%d", &n);
    string title, author, key_words, publisher, year;
    for (int i = 0; i < n; i++) {
        int id; 
        scanf("%d", &id); getchar();
        getline(cin, title);
        mpTitle[title].insert(id);  //建立书名和Id之间的映射
        getline(cin, author);
        mpAutor[author].insert(id);
        while(cin >> key_words) {
            mpKey[key_words].insert(id);
            char ch = getchar();    //接受key_words之后的字符
            if (ch == '\n') break;
        }
        getline(cin, publisher);
        mpPublisher[publisher].insert(id);
        getline(cin, year);
        mpYear[year].insert(id);
    }
    int m; scanf("%d", &m);
    while(m--) {
        int id; string op;
        scanf("%d: ", &id);
        getline(cin, op);
        cout << id << ": " << op << endl;
        if (id == 1) query(mpTitle, op);
        else if (id == 2) query(mpAutor, op);
        else if (id == 3) query(mpKey, op);
        else if (id == 4) query(mpPublisher, op);
        else query(mpYear, op);
    }
    return 0;
}

posted on 2021-02-19 23:10  翔鸽  阅读(47)  评论(0编辑  收藏  举报