1004 Counting Leaves ——PAT甲级真题

1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

题目大意:统计一颗树每一层叶子节点的数目。

大致思路:层序遍历这颗树,设置level数组,其中level(child) = level(parent) + 1。同时统计每一层叶子节点数目。

代码:

#include <bits/stdc++.h>

using namespace std;

const int N = 110;
vector<int> root[N];
int n, m;
int level[N], cnt[N];

void BFS(int x) {
    queue<int> q;
    q.push(x);
    level[x] = 1;
    int maxLevel = 1;
    while(!q.empty()) {
        int t = q.front(); q.pop();
        if(root[t].size() == 0) cnt[level[t]]++;
        for (int i = 0; i < root[t].size(); i++) {
            q.push(root[t][i]);
            level[root[t][i]] = level[t] + 1;
            maxLevel = max(level[root[t][i]], maxLevel);
        }
    }
    for (int i = 1; i <= maxLevel; i++) {
        cout << cnt[i];
        if (i != maxLevel) cout << " ";
        else cout << endl;
    }
}

int main() {
    cin >> n >> m;
    for (int i = 0; i < m; i++) {
        int id, k;
        cin >> id >> k;
        for (int j = 0; j < k; j++) {
            int x; cin >> x;
            root[id].push_back(x);
        }
    }
    BFS(1);
    return 0;
}

posted on 2021-02-10 17:43  翔鸽  阅读(33)  评论(0编辑  收藏  举报