1094 The Largest Generation ——PAT甲级真题

1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

题目大意:让你统计一颗树每层节点的最大数目,以及相应层次。

大致思路:用BFS统计层序遍历每一层节点,同时定义一个数组level用来记录每一层结点的高度,其中level(孩子节点) = level(父节点) + 1。定义一个数组cnt用来统计每一层结点的个数。

代码:

#include <bits/stdc++.h>

using namespace std;

const int N = 110;
vector<int> root[N];
int n, m;
int ans1, ans2;
int level[N], cnt[N];  //统计每一层树的高度和每一层的节点数

void BFS(int x) {
    queue<int> q;
    q.push(x);
    level[1] = 1;
    ans1 = 1, ans2 = 1;
    while (!q.empty()) {
        int t = q.front();
        q.pop();
        cnt[level[t]]++;
        // cout << cnt[level[t]] << endl;
        for (int i = 0; i < root[t].size(); i++) {
            level[root[t][i]] =
                level[t] + 1;  //孩子结点的层数等于父结点层数 + 1
            q.push(root[t][i]);
        }
    }
    for (int i = 1; i <= n; i++) {
        // cout << cnt[level[i]] << endl;
        if (ans1 < cnt[level[i]]) {
            ans1 = cnt[level[i]];
            ans2 = level[i];
        }
    }
    cout << ans1 << " " << ans2 << endl;
}

int main() {
    scanf("%d %d", &n, &m);
    memset(level, 0, sizeof(level));
    memset(cnt, 0, sizeof(cnt));
    for (int i = 0; i < m; i++) {
        int id, k;
        scanf("%d %d", &id, &k);
        for (int j = 0; j < k; j++) {
            int x;
            scanf("%d", &x);
            root[id].push_back(x);
        }
    }
    BFS(1);
    return 0;
}

posted on 2021-02-10 16:14  翔鸽  阅读(26)  评论(0编辑  收藏  举报