1079 Total Sales of Supply Chain ——PAT甲级真题

1079 Total Sales of Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

题目大意:给一棵树,在树根时货物卖出的价格为P,从父结点到子结点卖出的价格均比上一层提高r%,在叶子节点给出卖出的总人数,让你求出货物最后卖出的总价格。

大致思路:简单的树的遍历,每一个结点记录好自己卖出的价格和编号,利用DFS一次向下遍历。

代码:

#include <bits/stdc++.h>

using namespace std;

const int N = 1e5 + 10;
struct node {
    int id; //编号
    vector<int> child;  //孩子结点
    int total;  //卖出的总人数
    double cell;    //售价
}root[N];
int n;
double p, r, ans;
bool vis[N];

void newNode(int x) {
    root[x].id = x;
    root[x].child.clear();
    root[x].total = 0;
}

void DFS(int x) {
    //表示访问到根节点
    if (root[x].total != 0) {
        ans += root[x].total * root[x].cell;
        return;
    }
    //访问x的子节点
    for (int i = 0; i < root[x].child.size(); i++) {
        int tmp = root[x].child[i]; //子节点编号
        root[tmp].cell = (1 + r * 0.01) * root[x].cell;
        DFS(tmp);
    }
}

int main() {
    cin >> n >> p >> r;
    memset(vis, 0, sizeof(vis));
    ans = 0.0;
    for (int i = 0; i < n; i++) newNode(i);
    for (int i = 0; i < n; i++) {
        int k;
        cin >> k;
        if (k == 0) {
            int num; cin >> num;
            root[i].total = num;
            continue;
        }
        for (int j = 0; j < k; j++) {
            int x; cin >> x;
            vis[x] = true;  //非根节点标记一下
            root[i].child.push_back(x);
        }
    }
    int root_index; //根节点的编号
    for (int i = 0; i < n; i++) {
        if (!vis[i]) {
            root_index = i;
            break;
        }
    }
    root[root_index].cell = p;
    DFS(root_index);
    printf("%.1lf\n", ans);
    return 0;
}

posted on 2021-02-10 10:52  翔鸽  阅读(84)  评论(0编辑  收藏  举报