1095 Cars on Campus——PAT甲级真题

1095 Cars on Campus

Zhejiang University has 6 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<= 10000), the number of records, and K (<= 80000) the number of queries. Then N lines follow, each gives a record in the format

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each “in” record is paired with the chronologically next record for the same car provided it is an “out” record. Any “in” records that are not paired with an “out” record are ignored, as are “out” records not paired with an “in” record. It is guaranteed that at least one car is well paired in the input, and no car is both “in” and “out” at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:
16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00
Sample Output:
1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意:

让你模拟车库的停车过程。首先每辆车都有一个车牌号,和对应的时间和状态,如果状态是in表示入库,如果状态是Out表示出库。出库时间一定紧跟在入库时间之后,只有出库和入库像配对的才算做合法时间。给出K组查询,查询时间按照由小到大一次递增。每组查询要求你给出相应时间段内在停车库的车辆数。最终给出待在停车库内时间最长的车的车牌号以及相应时间。

大致思路

  1. 定义一个结构体用来存储各个车辆的信息。同时定义一个map用来建立车牌号和车辆信息之间的映射关系,方便后续对每辆车的进出时间进行排序。
  2. 对每一辆车的进出时间进行排序,同时按照题目要求判断合法的时间段,因为答案要求的是每辆车待在车库的最长时间,所以我们定义一个map<string, int> record用来记录每辆车待在车库里的时间,同时定义一个vector< pair<int, int> > during;用来记录每辆车的进入和离开时间。建立一个vector maxTime用来存储待在车库里最长时间的车牌号。
  3. 在查询时,把查询时间和during中的合法时间进行比较,如果查询时间大于进入时间表明有车进入如果查询时间小于进入时间表明有车离开。

代码

#include <bits/stdc++.h>

using namespace std;

const int N = 1e5 + 10;
struct node {
    string id, status;
    int hh, mm, ss;  //时,分,秒
    bool friend operator<(node a, node b) {
        if (a.hh == b.hh) {
            if (a.mm == b.mm) return a.ss < b.ss;
            return a.mm < b.mm;
        }
        return a.hh < b.hh;
    }
};
int n, k;
// typedef pair<int, int> P;
vector< pair<int, int> > during;
vector<string> maxTime;

int main() {
    scanf("%d%d", &n, &k);
    map<string, vector<node>> car;
    map<string, int> record;  //记录每辆车的进入时间和最大时间
    for (int i = 0; i < n; i++) {
        node tmp;
        cin >> tmp.id;
        scanf("%d:%d:%d", &tmp.hh, &tmp.mm, &tmp.ss);
        cin >> tmp.status;
        car[tmp.id].push_back(tmp);
    }
    //对每一辆车出入时间进行排序
    for (auto ite : car) {
        auto tmp = ite.second;
        sort(tmp.begin(), tmp.end());
        int len = tmp.size();
        for (int i = 0; i < len - 1; i++) {
            if (tmp[i].status == "in" && tmp[i + 1].status == "out") {
                int in_time = tmp[i].hh * 3600 + tmp[i].mm * 60 + tmp[i].ss;
                int out_time =
                    tmp[i + 1].hh * 3600 + tmp[i + 1].mm * 60 + tmp[i + 1].ss;
                int stay_time = out_time - in_time;
                record[tmp[i].id] += stay_time;  //记录每辆车待的最长时间
                during.push_back(make_pair(
                    in_time, out_time));  // during记录每一辆车的进来和出去时间
            }
        }
        if (maxTime.empty())
            maxTime.push_back(ite.first);
        else {
            if (record[ite.first] == record[maxTime[0]])
                maxTime.push_back(ite.first);
            else if (record[ite.first] > record[maxTime[0]]) {
                maxTime.clear();
                maxTime.push_back(ite.first);
            }
        }
    }
    while (k--) {
        int call_hh, call_mm, call_ss;
        scanf("%d:%d:%d", &call_hh, &call_mm, &call_ss);
        int last_time = call_hh * 3600 + call_mm * 60 + call_ss;
        int ans = 0;
        for (int i = 0; i < during.size(); i++) {
            if (last_time >= during[i].first) ans++;
            if (last_time >= during[i].second) ans--;
        }
        printf("%d\n", ans);
    }
    sort(maxTime.begin(), maxTime.end());
    for (int i = 0; i < maxTime.size(); i++) cout << maxTime[i] << " ";
    // cout << "最长时间为:" << record[maxTime[0]] << endl;
    int ans_hh = record[maxTime[0]] / 3600;
    record[maxTime[0]] %= 3600;
    int ans_mm = record[maxTime[0]] / 60;
    int ans_ss = record[maxTime[0]] % 60;
    printf("%02d:%02d:%02d\n", ans_hh, ans_mm, ans_ss);
    return 0;
}

运行结果如下图所示

posted on 2021-02-03 17:25  翔鸽  阅读(56)  评论(0编辑  收藏  举报