Bone Collector

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 117   Accepted Submission(s) : 42

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest 
#include <iostream>
using namespace std;

const int maxn=1010;
int c[maxn];
int w[maxn];
int bag[maxn];

int main()
{
    int T,n,m;
    cin>>T;
    while (T--)
    {
        cin>>n>>m;
        memset(bag,0,sizeof(bag));
        for (int i=1;i<=n;i++)
        {
            cin>>w[i];
        }
        for (i=1;i<=n;i++)
        {
            cin>>c[i];
        }
        for (i=1;i<=n;i++)
        {
            for (int j=m;j>=c[i];j--)
            {
                if (bag[j]<bag[j-c[i]]+w[i])
                    bag[j]=bag[j-c[i]]+w[i];
            }
        }
//        for (i=0;i<=10;i++)
//            cout<<bag[i]<<"   ";
        cout<<bag[m]<<endl;
    }
    return 0;
}

 

posted on 2013-09-02 11:10  不知妖精  阅读(211)  评论(0编辑  收藏  举报

导航