Phone List

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source

2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)
#include <iostream>
using namespace std;
#include <string>
const int maxn=10;
int count=0;

struct node 
{
    node *next[maxn];
    int step;
};

void Create(node *T,char *str)
{
    int len=strlen(str);
    for (int i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if (T->next [id]==NULL)
        {
            node *p=(node *)malloc(sizeof(node));
            p->step =1;
            for (int j=0;j<maxn;j++)
                p->next [j]=NULL;
            T->next [id]=p;
            T=T->next [id];
        }
        else
        {
            T=T->next [id];
            T->step =T->step +1;
        }
    }
}

int Find(node *Q,char *str)//查询的过程类似
{
    int len = strlen(str);
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'0';
        if(Q->next[id] != NULL)
        {
            Q = Q->next[id];
        }
        else
        {
            return 0;
        }
    }
    return Q->step;
}

void Deal(node *T)
{
    if (T==NULL)
        return ;
    for (int i=0;i<maxn;i++)
    {
        if (T->next [i]!=NULL)
            Deal(T->next [i]);
    }
    free(T);
}
   
int main()
{
    int N,M;
    char str[10000][20];
    
    while (cin>>N)
    {
        while (N--)
        {
            node *T=NULL;
            T=(node *)malloc(sizeof(node));
            T->step =1;
            for (int i=0;i<maxn;i++)
            T->next [i]=NULL;
            int flag=0;
            cin>>M;
            getchar();
            for (i=0;i<M;i++)
            {
                gets(str[i]);
                Create(T,str[i]);
            }
            for (i=0;i<M;i++)
            {
                if (Find(T,str[i])>1)
                {
                    cout<<"NO"<<endl;        //老是这个"No"没有大写。。。
                    flag=1;
                    break;
                }
            }
            if (!flag)
                cout<<"YES"<<endl;
            Deal(T);
        }
    }
    return 0;
}

 

posted on 2013-08-24 09:45  不知妖精  阅读(198)  评论(0编辑  收藏  举报

导航