HNU 10370 Balloon Comes!

Balloon Comes!
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 196, Accepted users: 168
Problem 10370 : No special judgement
Problem description
  The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!


Input
  Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.

Output
  For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input
4
+  1  2
-  1  2
*  1  2
/  1  2
Sample Output
3
-1
2
0.50

 

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include <iomanip>


using namespace std;
int main()
{
    int a,b,n;
    char op;
    cin>>n;
    while(n--)
    {
        cin>>op>>a>>b;
        switch(op)
        {
            case '+': cout<<a+b<<endl;break;
            case '-': cout<<a-b<<endl;break;
            case '*': cout<<a*b<<endl;break;
            case '/': if(a%b==0) cout<<a/b<<endl;
                      else printf("%.2f\n",(float)((double)a/(double)b));
                        break;
        }

    }
    //system("pause");
    return 0;
}

 

posted @ 2013-11-17 14:44  褪色的狼  阅读(137)  评论(0编辑  收藏  举报