HNU 10369 A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 221, Accepted users: 213
Problem 10369 : No special judgement
Problem description
  Your task is to calculate the sum of some integers.

Input
  Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
  For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10

15

6

 

#include<iostream>
using namespace std;
int main()
{
    int a,b,i,n;
    cin>>n;
    while(n--)
    {
        cin>>i;
        cin>>a;
        for(;(i-1)>0;i--)
        {
            cin>>b;
            a+=b;
        }
        cout<<a<<endl<<endl;
    }
    return 0;
}

 

 

posted @ 2013-11-17 14:14  褪色的狼  阅读(203)  评论(0编辑  收藏  举报