HNU 10366 A+B for Input-Output Practice (VI)

A+B for Input-Output Practice (VI)
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 268, Accepted users: 252
Problem 10366 : No special judgement
Problem description
  Your task is to calculate the sum of some integers.

Input
  Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

Output
  For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15

 

#include <iostream>

using namespace std;
int main()
{
       int a,b,s,i;
        while(cin>>i)
        {
            cin>>a;
            s = a;
            for(;(i-1)>0;i--)
                {
                    cin>>b;
                    s+=b;
                }
            cout<<s<<endl;
        }
       return 0;
}

 

 

#include <iostream>
using namespace std;

int main()
{
    int N,i;
    while(cin >> N)
    {
        int sum = 0;
        while (N--)
        {
            cin >> i;
            sum += i;
        }
        cout << sum << endl;
    }

return 0;
}

 

posted @ 2013-11-17 10:55  褪色的狼  阅读(245)  评论(0编辑  收藏  举报