HNU 10365 A+B for Input-Output Practice (V)

A+B for Input-Output Practice (V)
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 294, Accepted users: 278
Problem 10365 : No special judgement
Problem description
  Your task is to calculate the sum of some integers.

Input
  Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
  For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15

 

#include <iostream>

using namespace std;
int main()
{
       int a,b,s,n,i;
       cin>>n;
       for(;n>0;n--)
       {
            cin>>i;
            cin>>a;
            s = a;
            for(;(i-1)>0;i--)
                {
                    cin>>b;
                    s+=b;
                }
            cout<<s<<endl;
       }
       return 0;
}

 

posted @ 2013-11-17 10:46  褪色的狼  阅读(203)  评论(0编辑  收藏  举报